EQDKP Backups Not Showing Up on Webpage

  • EQDKP Backups Not Showing Up on Webpage

    Recently I migrated our EQDKP+ install to a new host, transferred all the files and databases and everything is working fine. However, whether I use Manual backup (Save to Server) or through Cronjob, the backups are not showing up on the Recover Backup tab. It also says on that page:

    To restore backups from other EQdkp Plus installations with the same version, upload the backups to the folder "./../data/89bcd0fc6fb97c6b10f9a9cbb8420bb1/eqdkp/backup/".

    When I SSH into server and navigate to that folder, there's no files in it.

    Is there any way to edit the backup location through one of the php config files or does anyone have any thoughts as to what's going on?

    Thanks!
  • No, there is no way to change the backup location.

    On migrition to your new host, you didn't rename the data folder, as described here: eqdkp-plus.eu/wiki/Move_to_another_Host#data-Folder

    Therefore, the backup folder is of course empty, because it looks at the new location.
    Viele Grüße,
    GodMod

    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken - Spenden | You want to thank me - Donate.

  • GodMod schrieb:

    I meant copied from your old installation. If you had already backups, they must be there.
    I didn't have any backups when I transferred over from old host. I created a manual backup and downloaded it and imported it into phpmyadmin on the new host.

    ...

    I did notice that there appears to be a /meta folder inside of the /backup folder, where it appears files named like backups are stored. Could this be a clue?


  • As the name says, it's just metadata, nur data from the backups.
    Uploaded backups to the named folder have to follow name convenction, als you can see at the filenames from the metafiles. Otherwise our Backup tool does not reckognize them.
    Viele Grüße,
    GodMod

    Bitte sendet mir keine unaufgeforderten Support-PNs. | Please don't send me unwanted support-PMs.
    Du willst dich bei mir bedanken - Spenden | You want to thank me - Donate.

  • I return with more information!

    So I ended up messing around with it a bit, I noticed some oddities. If I select "zip" from the backup type, it will not save to the backup folder, and if I choose Download, it downloads a 0byte file (Only for zip).

    I found that it does not do this if I select the "text" option instead when doing a manual backup, it correctly saves a backup into the backup folder as a .sql file and downloads the file as well.

    So what I ended up doing was editing the backup cronjob to make it run it as a text backup instead of a zip. For those who may be having similar problems with .zip backups, in the ~/core/cronjobs folder, edit/open the backup_crontask.class.php file.

    Scroll down until you find the part:

    Quellcode

    1. public function run(){
    2. $blnResult = $this->backup->createDatabaseBackup('zip', true, false, true);
    3. $log_action = array(
    4. '{L_TABLES}' => '{L_ALL}',
    5. );
    6. $this->logs->add("action_backup_created", $log_action, $this->config->get('plus_version'), $bln$


    Now what you want to do is, at the part starting with $blnResult, inside the parenthesis right after createDatabasseBackup, you want to change the part that says 'zip' to 'text'

    So it should look like this:

    Quellcode

    1. public function run(){
    2. $blnResult = $this->backup->createDatabaseBackup('text', true, false, true);
    3. $log_action = array(
    4. '{L_TABLES}' => '{L_ALL}',
    5. );
    6. $this->logs->add("action_backup_created", $log_action, $this->config->get('plus_version'), $bln$

    Save your edit, and reload your eqdkp page and try running the cronjob manually, then check your Recover Backup page to verify that it saved/created a backup.

    ---------------

    I'm still messing around with it a bit, trying to figure out why it's having such a problem saving .zip backups. I'm thinking it might be a permissions issue, but I've recursively set the data folder and all subfolders/files to the correct permissions. Any suggestions would be helpful!